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The Geospatial Education and Outreach Project (GEO Project) is a collaborative effort among the Geosystems 
Research Institute (GRI), the Northern Gulf Institute (a NOAA Cooperative Institute), and the Mississippi State 
University Extension Service. The purpose of the project is to serve as the primary source for geospatial 
education and technical information for Mississippi. 

The GEO Project provides training and technical assistance in the use, application, and implementation of 
geographic information systems (GIS), remote sensing, and global positioning systems for the geospatial 
community of Mississippi. The purpose of the GEO Tutorial series is to support educational project activities and 
enhance geospatial workshops offered by the GEO Project. Each tutorial provides practical solutions and 
instructions to solve a particular GIS challenge. 
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REQUIRED RESOURCES 

• QGIS (3.16.9-Hannover) 

FEATURED DATA SOURCES 

• Tutorial data: https://www.northerngulfinstitute.org/projects/rgmg/Q_Digitize.zip 

• Sanborn Fire Insurance Map from Biloxi, Mississippi, May 1914. Map. Retrieved from the Library 
of Congress, <www.loc.gov/item/sanborn04432_005/>. 
  

OVERVIEW 

This tutorial demonstrates how to digitize points, lines, and polygons in QGIS. More specifically, it focuses 
on the on-screen digitizing, also known as heads-up digitizing, since it is carried out while you look directly 
at the computer screen. The on-screen digitizing is a process of tracing features on a raster dataset and 
converting these features to vector layers for effective use in a GIS. Learning how to digitize is vitally 
important for any GIS expert, as it allows you to create new spatial datasets, required for mapping or 
geospatial analysis.  

To perform the steps listed below, you will use a georeferenced historic fire insurance map from Biloxi, 
Mississippi as a raster dataset based on which you will trace the vector features. The key objective is to 
digitize city blocks and fire hydrants within the fire limits zone, as well as a segment of railroad located 
just to the north of that zone. This will allow you to practice creating vector features of different 
geometry types. You will also learn how to use essential QGIS digitizing tools.   

https://www.northerngulfinstitute.org/projects/rgmg/Q_Digitize.zip
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STEP 1. DOWNLOAD THE TUTORIAL DATA 

A. The original historic map used in this tutorial is available online in the Library of Congress Sanborn 
Maps collection. However, it is not georeferenced and cannot be directly used in digitizing 
process. If you would like to review the original map, you can access Image 1 of Sanborn Fire 
Insurance Map from Biloxi, Mississippi, May 1914 using the following link: 
http://www.loc.gov/resource/g3984bm.g3984bm_g044321914/?sp=1  

B. For the purpose of this tutorial, the georeferencing process has been already completed. In 
addition, the original map has been cropped to the area that needs digitizing. You can download 
the georeferenced map and other datasets required for this tutorial using the link provided in the 
data sources section.  

C. Save the zipped file to your local drive, preferably to a folder where you will store all files created 
in this tutorial. Extract the content of the zipped folder to the same directory and review available 
datasets.  
 

 

STEP 2. START QGIS AND OPEN AN EXISTING PROJECT 

A. Start QGIS and then open the Digitizing.qgz project (Project > Open). Browse to the folder where 
you saved your tutorial data. Select the project name and click Open. 
 

 
 

B. The Digitizing.qgz project will automatically open to the extent that needs digitizing. This area 
corresponds to the fire limits zone, delineated on the Sanborn Fire Insurance Map with a solid red 
line. To help you during the digitizing process, the QGIS project has this area bookmarked. This 
way you can easily return to the same location (Browser window > Spatial Bookmarks > 
Biloxi_digitizing). The project coordinate reference system (CRS) is set to NAD83(2011) / 
Mississippi TM, commonly used for this geographic location. The project has two available layers: 
the fire_limits and Hst_map_TM. Review their properties (right-click on the layer name > 
Properties). Note that the fire_limits layer is a vector type, represented by a small square icon 
next to the layer’s name. The Hst_map_TM is a raster layer, and it is symbolized by a small, 

http://www.loc.gov/resource/g3984bm.g3984bm_g044321914/?sp=1
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pixelated square. For practice, turn on and off each layer (click the checkmark next to the layers’ 
name), also zoom in and out to the extent of each layer (right-click on the layer name > Zoom to 
Layer).  
 

 

STEP 3. CREATE A NEW POINT LAYER AND DIGITIZE HYDRANTS 

A. The objective of this step is to digitize hydrants located within the outlined fire limits zone. You 
will start this tutorial by working with points, as point features are the most basic and easy to 
digitize. Before you can start digitizing you need to create a layer that will hold the digitized 
features. Create a new shapefile (Layer > Create Layer > New Shapefile Layer…).  
 

 
 

B. Navigate to your tutorial Data folder and name the shapefile hydrants.shp. Change the Geometry 
Type to Point. Make sure that the CRS is set to NAD83(2011) / Mississippi TM. Note that the id 
column (integer field type, length 10) is added automatically. Click OK.  
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C. The empty hydrants layer will be automatically added to the Layers panel. Note a small point 
marker next to the hydrants layer’s name, indicating that this is a point layer. The color of this 
marker was assigned randomly, and it may be unsuitable for your digitizing needs. This can be 
easily adjusted by changing the symbology properties.  
 

 
 

D. On the historic map, hydrants are represented with solid black point symbols. To clearly 
distinguish newly digitized hydrant features from the original ones, it might be helpful to modify 
the symbology of the layer and select a contrasting color. Right-click the hydrants layer and select 
Properties > Symbology. Select the Simple Marker symbol, change Size to 5 Points, and select 
orange as the Fill color. Click Apply and then OK.  
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E. To be able to digitize points you need to activate editing for the hydrants layer. Make sure this is 
the active layer by clicking on it, then right-click and select the Toggle Editing button. This action 
enables point editing tools on the digitizing toolbar. Also, a tiny pencil appears next to the layer’s 
name indicating that this layer is being currently edited.  
 

 
 

F. Click on the Add Points Feature button . Hover the mouse cursor over the map and note that 
the cursor changed shape from an arrow to a scope-style symbol. This means that you are ready 
to add point features to the hydrants layer.  
 

 
 

G. Simply click on one of the solid black points visible on the 
historic map. The Feature Attributes window will 
automatically appear. Type 1 into the id line and click OK.  
This will create the first point. 

H. Verify that the point was created correctly by opening the 
attribute table. Right-click on the hydrants layer and 
select Open Attribute Table. At this stage, the table should 
contain only a single record.  
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I. Continue adding points for hydrants located within the fire limits zone. Make sure to assign 
successive feature id numbers to newly added points. Use the undo (Ctrl+Z) and redo 
(Ctrl+Shift+Z) buttons in case you make mistakes. You can also enable the Undo/Redo panel to 
see your editing history. Periodically save your edits (Save Layer Edits). 
 

 
 

J. Once finished you should have 47 hydrants traced. To view the digitized points more clearly, turn 
off the Hst_map_TM layer. Make sure to save all edits and click on the pencil button (Toggle 
Editing) to close the editing session. Turn on the Hst_map_TM layer back on, before proceeding 
to the next step. 
 

STEP 4. CREATE A NEW LINE LAYER AND DIGITIZE THE RAILROAD 

A. In this step, you will digitize a short section of the Louisville and Nashville Railroad located just to 
the north of the fire limits zone. The process of digitizing line features is very similar to digitizing 
points. First, you create an empty layer and then you toggle editing to create features. The key 
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difference is that each time you click you create a vertex that connects line segments. Create a 
line shapefile (Layer > Create Layer > New Shapefile Layer…) called railroad.shp. This time, choose 
Line as the Geometry Type, create an additional text field called Rail_Name (text field type, length 
50), click the Add to Fields List button to add this field to the list, and then OK to create the layer. 
 

 
 

B. The railroad layer will be loaded on top of the hydrants layer in the Layers panel. Note a small line 
symbol next to the layer’s name indicating a line geometry type. Click the layer to activate it. 
Change the symbology of the line layer (Properties > Symbology). To create a basic railway 
symbol, to the existing Simple Line symbol you need to add an extra line symbol (click the green 
plus sign). Change the Symbol Layer Type of the added line to a Hashed Line and choose the Hash 
placement with an interval of 10 points. Select a dark gray color for both the simple as well as the 
hashed line. Click Apply and then OK to accept changes in railroad layer symbology.   
 

 
 

C. Begin editing by clicking on the Toggle Editing button and zooming into a northern boundary of 
the fire limits zone as shown below.  
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D. Click on the Add Line Feature button to start digitizing the railroad. Note that this time, line 
digitizing tools were activated to allow editing line vertices. 
 

 
 

E. Similarly to the point digitizing, the mouse cursor changes to a crosshair symbol indicating a 
digitizing mode. To help you move around the area that needs digitizing, use the mouse wheel to 
zoom in and out. Begin by clicking on the black rail line east of the northeast corner of the fire 
limits zone and finish the line at the northwest corner. This segment of the railroad is relatively 
short and straight, so you do not need a lot of vertices to accurately digitize it. Click 5 to 7 times 
to trace the railroad. Each time you click, make sure that your newly created line does not 
intersect with the fire limits zone. Right-click to finish the line feature.  

F. The Feature Attributes window will automatically 
appear. Type 1 into the id line and Louisville & 
Nashville R.R. into the Rail_Name line. Click OK.  This 
will create the first and, in this case, only line feature.  

G. Save the edits and view the results. Open the 
attribute table and turn off the Hst_map_TM layer to 
better see the created line feature.  
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STEP 5. CREATE A NEW POLYGON LAYER AND DIGITIZE CITY BLOCKS 

A. In this step, you will digitize city blocks located within the fire limits zone. In this case, polygons 
are the most appropriate geometry type to be used. Turn the Hst_map_TM layer back on and 
then create a polygon shapefile (Layer > Create Layer > New Shapefile Layer…) called 
city_blocks.shp. This time choose Polygon as the Geometry Type, create an additional numeric 
field called block_nmb (Whole Number field type, length 10), click the Add to Fields List button to 
add this field to the list, and then OK to create the layer. 
 

 
 

B. The city_blocks layer will be loaded into the Layers panel. Drag it, to place it below the hydrants 
layer. Note a small square symbol next to the layer’s name, indicating a polygon geometry type. 
Click on it to activate the layer.  

C. Change the symbology of the city_blocks layer (Properties > Symbology). Select your favorite fill 
color and change the opacity to 50%. This way you will be able to clearly see segments that need 
tracing.  
 

 
 

H. The digitizing process for lines and polygons is very similar. Both feature types have vertices 
representing turns and corners and both require you to right-click to end tracing. The key 
difference is that lines are open (the first and last pairs of coordinates are different), while 
polygons are closed (the first and last pairs of coordinates are the same). Occasionally this creates 
problems while tracing polygons, especially when the digitized shapes are complex, as they may 
cover up sections that still need to be digitized. Begin editing by clicking on the Toggle Editing 
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button and zooming in to the northeastern corner of the fire limits zone, specifically focusing on 
city block number 15.  

I.  

 
 

D. Select the Add Polygon tool. Click on one of the corners of the city block 15 and start tracing. 
After you trace all four corners, right-click to create the polygon. To avoid confusion, enter only 
the block number, listed on the historic map, in this case 15. Do not enter the id number at this 
time, keep it NULL.  
 

 
 

E. Continue digitizing the remaining city blocks. The order of tracing is not important, but it might be 
a good idea to trace the city blocks in the order they are numbered on the historic map. This way 
you will lower your chances of entering a wrong block number into the attribute table. Save edits 
periodically       . 

F. Once the city blocks are digitized you should have 32 polygons created. Turn off the Hst_map_TM 
layer to better see the results. When you are satisfied with your work, save edits, and click on the 
pencil button (Toggle Editing) to close the editing session. 

G. An important part of digitizing is working with attribute tables and populating existing fields. 
Review the attribute table of the city_blocks layer. Right-click on the city_blocks layer and select 
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Open Attribute Table. Note that the polygon id field is listing only NULL values when it should list 
consecutive ID numbers. You can enter these numbers manually, but this is not a very efficient 
approach. Instead, you can correct this issue in one easy step, by using the field calculator.  
 

 
 

H. Click on the Open field calculator button and check the Update existing field box. From the drop-
down menu select the id field. In the expression box, type in: $Id and click OK to execute the 
expression. 
 

 
 

I. The field calculator expression will add unique numbers to the id field. This method is significantly 
more efficient than entering consecutive numbers for each digitized polygon manually.  
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J. To complete the digitizing process, you should always review your work. Make sure that all your 
digitized layers are visible. Look for potential mistakes or misplaced features. At this stage, you 
can easily edit all layers, by enabling editing for each and making final adjustments.  

K. As a last touch, it might be a good idea to label the city_blocks layer. Click on the Layer Labeling 
Options button. In the Layer Styling panel, select Single Labels’ type, city_blocks layer, and 
block_nmb as the Value field. Click Apply to generate labels. Note that the labeling options can 
also be accessed by double-clicking the layer to open the properties window. 
 

 
 

L. Save the Digitizing.qgz project and exit QGIS. 
 

This concludes our GEO Tutorial. The point, line, and polygon features have been successfully 
digitized based on the historic fire insurance map. The created vector layers can be used to analyze 
the distribution of historic features, create professional maps, or generate spatial overlays for use in 
more complex geospatial workflows. In a nutshell, the key benefit of on-screen digitizing is the ease 
of creating new datasets fitted specifically to the requirements of your geospatial project.  

 


